Sourceforge CVS Access
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Introduction

This document is intended to help you connect to the CVS server on a Windows system.

Sourceforge uses SSH2 encryption to secure access to its servers. The following will help you
get set up pretty easily.

Tools
First thing we need is the right tools. Download the following items.

Putty — the SSH tools — (version as of writing is 0.55)
http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html|
o PUuTTY
e Pageant
e PuTTYgen
¢ Note: all the tools can be downloaded in one zip file

TortoiseCVS — the CVS client — (version as of writing is 1.6.1)
http://tortoisecvs.sourceforge.net/download.shtml
e TortoiseCVS

See addendum at end of document on the following updated software versions:
e TortoiseCVS 1.8.1

Generate Public / Private Keys

The keys are important for unique authentication and so you don’t have to enter a password
every time you access the servers.

Run the PuTTYgen program.


http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
http://tortoisecvs.sourceforge.net/download.shtml

PulTY Key Generator,

Public: and private key generation for PuTTY
=1

Mo key.

Achions

Generate a public/private key pair
Load an existing private key file

Save the generated kep

Parameters

Type aof key to generate:
() 55H1 [RS4) (O 55H2 RSA

MHumber of bits in a generated key; 1024

1. Be sure to select the SSH2 DSA option at the bottom

PulTY Key Generator,

Public and private key generation for PuT T
Ky

Please generate zome randomness by moving the mouse owver the blank area.

Actiong
Gernerate a public/private key pair
Load an existing private key file

Save the generated kep

Farameters

Type of key to generate:

Mumber af bits in a generated key: l:l

2. Click the generate button and move the mouse in the grey area until the key is full
generated



PulTY Key Generator, @El

Public: and private key generation for PuTTY

=1

Public key for pasting into OpenS5H authorized_keys2 file:

ssh-dss ~
AabAR INzalTkcIMAAACAR dfaCIzo0Ry7NIU leqgR gkl vsBh avBlBx+bhd+3T 2Gr
B+9niZaR TJAOIGE WY mgdBM 1w/ Tl BIEGY gNqoyi=SUE/|BJ »rDiE09asabR 80julbiG e
Bl4RUYg+SERZpE YU RC+ el lek T gs2rS OKDrohcak 3HX1 i2wT F+GPMAAAANARFD)
AvwiuifelhPIEMY 3¢5 FlwgsZ 30aA4 00 o jsB w1 vi0 To1 D ofOplJLE Pwkmnip) s
K.ey fingerprint; egh-des 1023 (569 a1:11:5e: 11, 32:d8: 291 7. 020871 2. 36:c0:1b
K.ey comment: homel

Key passphraze:

Confirrn passphrase:

Achions

Generate a public/private key pair
Load an existing private key file
Save the generated key Save public key ] ’ Save private key ]
Parameters

Type aof key to generate:

() 55H1 [RS4) () 55H2 RSA (3) S5H2 DSA

MHumber of bits in a generated key; 1024

3. Enter a comment you can use to identify the key. You can have multiple keys for
different computers. | have one for work and one for home. That way if the work key is
compromised | can replace it without changing my home key. (make sure the key
generated is SSH2 DSA or it won't work. I've been caught on this before).

Public: and private key generation for PuTTY

=1

Bublic key for pasting into OpenS5SH authorized_keys2 file:
ssh-dss ~
AabAR INzalTkcIMAAACAR dfaCIzo0Ry7NIU leqgR gkl vsBh avBlBx+bhd+3T 2Gr
B+9niZaR TJAOIGE WY mgdBM 1w/ Tl BIEGY gNqoyi=SUE/|BJ »rDiE09asabR 80julbiG e
Bl4RUYg+SERZpE YU RC+ el lek T gs2rS OKDrohcak 3HX1 i2wT F+GPMAAAANARFD)
AvwiuifelhPIEMY 3¢5 FlwgsZ 30aA4 00 o jsB w1 vi0 To1 D ofOplJLE Pwkmnip) s

K.ey fingerprint; egh-des 1023 (569 a1:11:5e: 11, 32:d8: 291 7. 020871 2. 36:c0:1b
K.ey comment: wrk,

Key passphraze: (1]}

Confirrn passphrase: (1]}

Actions

Generate a public/private key pair
Load an existing private key file

Save the generated kep Save public key ] ’ Save private key ]
Parameters

Type aof key to generate:

() 55H1 [RS4) () 55H2 RSA (3) S5H2 DSA

MHumber of bits in a generated key; 1024

4. Optionally enter a passphrase for the key. The passphrase is used to keep anyone else
from being able to use your key without a password. This would be good if you share
your machine with others. However, it sucks to have to enter the password everytime
you reload the key (say on reboot, etc)



Save private key as:

-1

‘_'\lﬁ

by Fecent
Dacurments

(C
Desktop
My Documents
Fy Computer

Ay Metwork.

Save in: | ) putty

ge-Wark.ppk

Mystafer-SourceFaor
@‘ pageant.exe
pageant-init,bat
f plink. exe

psCpLEXE
f psftp.exe
putty . cnt
putky . exe
©)putty hlp
putty.log
puttygen.exe
E Start Pagednt

test,dss

File name: | Mustafer-SourceForge-wiork. ppk.

]

[ Save

Save as lype: | All Files

3

[ Cancel

5. Click the ‘Save private key’ button. Most keys end with a .ppk extension. Don'’t worry
about saving the public key since you can load the private key into PuTTYgen to retrieve

it later if needed.

6. Copy the public key text in the large list box area to the clipboard for use in the next step.
The string should start with ssh-dss and end with whatever the comment was in your
comment box. This is the data that will be given to the sourceforge site.

Configuring Sourceforge Account

Now that you have a public / private key pair, you need to give load the public key into your
Sourceforge account. Once sf has your public key, the sf servers will be able to authenticate you

based on your private keys.

Go to sourceforge and log in to your account.

https://sourceforge.net/account



https://sourceforge.net/account
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Click the account options link in the center of the screen

TR et e i, irmwt Mrapmspan - Mot (bt | alnet L
R e fpe bk e =
G- -0 HEG Jem i@ 3-5% B-U8
T T ——— - Q=
G s o et g i O v ' G
s ey glnse i @irw glred gl i fees s g Rean il ] s Eiss 5B f] Gl -

R

L]

e I e R e

staptalie ulige af your Boucel ope fet uber sctoutt actound nastetencl SpfarT

& Bt e tho pisge -
1] E'm

Scroll down in your account and click the link that says ‘[Edit SSH Keys for Shell/CVS]’

The number next to this link will probably be zero.
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Paste the public key string from the PuTTYgen program into the text box on it's own line. Then
click the update button.

It may take up to 10 minutes before sourceforge will update the shell / cvs servers with the keys
so you will need to be a little patient in the following steps if it doesn’t work right away.



Loading Private Keys for Authentication

The private keys need to be loaded using the Pageant application. This program will need to be
running whenever you attempt to access Sourceforge via CVS or you will be prompted with a
password over and over.

)

When pageant is started, it minimizes to the system tray. You will need to locate it and double
click it.

Pageant Key List |"? I[il

[ e | Fartstron Ky
Help

It will not have any private keys loaded. Click the ‘Add Key’ button to load the private key you
generated earlier.

Select Privale Key File

Lock i | I3 putty “ O F M
" Myt alor - Sour o or g Wiork.ppk
=
“ Brpowat coe
My Fecerdt | [Elpageantint bat
Documents | park ece
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y Fies o s A ke - Canerl
My H ] Dyt st esnd-oride

If you entered a passphrase when you saved your key in the PuTTYgen program, you will be
prompted to enter it at this time.



Pageant Key List @E|

sshedss 1024 bbe7e:00:f1:99:75:74: 206 07:3d: Be: 320 786D 0T work

Once the key is loaded it should appear similar to this screen. You can click the X button and
Pageant should minimize to your system tray.

To automate the process of loading the key so that you don’t need to perform these steps every
time you reboot, a batch file can be created that can be added to your startup list. This will
automatically load the private key file and keep pageant minimized to the system tray.

An example batch file that should work for Windows 2000 / XP systems is as follows:

@echo off

@iF "%0S%" == "Windows_ NT" setlocal

set PUTTYDIR=%~dp0%
start %PUTTYDIR%pageant.exe %PUTTYDIR%Mystafer-SourceForge-Work.ppk

Testing Authentication

All sourceforge users are given shell access to the shell.sourceforge.net server. If the SF servers
have caught up with the posted public key change and everything is configured right, you should
be able to connect to the server without being prompted for a password.

To test the connection we will use the putty.exe program.



PuTTY Configuration

Categor:

[=)- Session
Logging
=~ Terminal
K.epboard
Bel
= Window
Appearance
Behaviour
Tranzlation
Selection
Colours
=- Cannection
Telnet
Filogin
= S5H
Auth
Tunnels

Basic options for your PUTTY session
Specify your connection by host name or [P address

Hogt Mame [or P address) Port
|shell.sourceforge.net | |22 |
Pratocol:

Baw (O Telnet (O PRlogin - (3) 55H

Load, save or delete a stored session

Saved Sessions
sf ghell account

Drefault S eftings

Load

Cloze window on exit:

O Always (O Mever (3 Only on clean exit

1. Enter shell.sourceforge.net in the Host Name box

2. Click the SSH button
3. Enter a name in the saved session box

PuTTY Configuration

Categony:

[=- Sessioh
Logging

[=- Terminal
Feybaoard
Bel

= Window
Appearance
Behaviour
Tranzlation
Selection
Colours

Telnet
Rlogin
=-55H
Auth
Tunhels

Options controling the connection

Sending of null packets to keep sezsion active

Seconds between keepalives [0 to tun off] EI

Low-level TCP connechion options
Dizable Magle's algorithr [TCP_MODELAY aption)

[rata to zend to the server
Teminal-type string

Auto-login usermame

neel

4. Click ‘Connection’ in the category tree

5. Enter your SF username in the ‘Auto-login username’ textbox




PulT¥ Configuration

Category:
= Session Options contralling S5H connections
Lagaing D'ata to gend to the server
=~ Terminal Remate command:
Kepboard
Bel
(=) Window Protocol optionz
.:.pEea.rance [ Don't allocate a pseudo-terminal
Te a\l"lot.ur [1Enable compression
ranzlation
S election Freferred SSH protocol version:
Colours O1 . @ c :
o Connection Dlmltate S5H 2 MALC bug in commercial <= w2 3¢
Telnet Encryption options
Rlogin Encrypption cipher selection policy:
AES [S5H 2 only) o]
?uth | Elowish =
unnels 3DES Down
- warn below here -
DES
[1Enable non-standard use of single-DES in S5H 2

6. Click ‘SSH’ in the category tree
7. Select ‘2’ for the ‘Preferred SSH protocol version’

PuTTY Configuration

Categony:
=- Session B asic options for your PuTTY session
Lagaing Specify your connection by host name or [P address
= Teminal Hoszt Mame [or [P address] Port
Keyboard |shell.sourceforge.net | |22 |
Bell
- Protocal:
=) Window .
Appeaiance () Raw () Telmet (O Rlogin () 55H
Behaviour Load, save or delete a stored session
Translﬁtlon Saved Sessions
Selection
sf shell account
Colours -
&- Connection Default Settings
f shell acoount
Telnet
Rlogin
= 55H
Auth
Tunnels
Cloze window on exit:
O phways O Mever (3 Only an clean exit

8. Return the ‘Session’ in the category tree
9. Click the ‘Save’ button to save the session that was entered
10. Click the ‘Open’ button to connect to the sourceforge server



PulTY Security Alert E

The server's host key is not cached in the regiskry, You
! } hawve no guarantee that the server is the computer wou

think it is.

The server's key fingerprint is:

ssh-dss 1024 4c:68:03:d4:50:58:a6:1d:9d:17:13:24: 14:48:ba: 99

IF wou trust this host, hit Yes to add the key bo

PUTT's cache and carry on connecting.

If wou wank ko carry on connecting just once, without

adding the key to the cache, hit Na.

IF wou do nok trust this host, hit Cancel ko abandon the

conneckion,

| es | [ Mo ] [ Cancel l

11. When prompted about the server’s key fingerprint, click the Yes button to trust the
connection.

= shellsourcelonge. el - Pal TY

12. If all is well, you should see a screen similar to the following without being prompted for a
password for access.

If you are prompted for a password and pageant is running with your private key, it may be
possible that your public key has not yet been updated on the shell server. You can verify this by
running a cat command on the .ssh/authorized_keys. If the key you generated earlier is in this
file then the server has been updated, otherwise you may need to wait longer and try
reconnecting for the test to be successful.



Connecting to JOpt CVS

First install the TortoiseCVS program that was downloaded. This will require a reboot of the
system after install ®

Once you have rebooted, you will need to launch the TortoiseCVS preferences application

= TorloEelVs - Preflerences
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GOH pararester: E

Enter -2’ in the SSH parameters text box to tell tortoise to use SSH2 protocol when using a
secure shell for communication. Click ok to close the window.



You now need to open an explorer window.
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Navigate to a directory you wish to contain the source code structure, right click on the directory
and select the ‘CVS Checkout...” command.



* TortolseCVS - Checkout Maodule
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Select ‘Secure shell (:ext:)’ as the protocol
Enter cvs.sourceforge.net as the server

Enter /cvsroot/jopt for the repository folder
Enter your SF username in the user name box
Enter csp in the Module box

Click the ok button

Checking oul s C-lsrlare - TerbsielVs EIEE

[ ]

If you see a screen similar to this and are not prompted for a password you have successfully
connected to CVS.



CVS Basics

The following basic commands are used when working with CVS:

1.

update — used to get the latest code, any changes will be merged with files that are
updated locally

add — used to add files to the cvs repository that are not already in the version system
remove — used to delete file from the cvs repository that are not already in the version
system

commit — used to write modifications, additions and removals from your local file system
to the cvs repository

Please add meaningful comments to all items that are committed.

Note: you cannot rename or move files once added to CVS. You will need to remove existing
files and add the new ones.

Rolling back changes to a previous version can be done by right clicking on a file and selecting
‘History..."” from the CVS submenu. You can right click on any previous version and save that
over the current version before committing.

You can also click ‘Weblog...” option from the CVS submenu for a file to see a list of changes and
commits made for each file within your web browser.



CVS with Eclipse

1. From the main menu, select Window -> Preferences
2. Innav tree, select Team -> CVS -> Ext Connection Method
3. Select the ‘Use another connection method type to connect’ option
4. Select ‘extssh’ in the drop down
5. Inthe nav tree, select Team -> CVS -> SSH2 Connection Method
6. Eclipse cannot use putty keys so we will create a new one
a. Click the key management tab
b. Click ‘Generate DSA Key...’
c. Type a comment in the box like ‘work — eclipse’
d. Copy the generated public key text into your SF account page
e. Save the private key using the ‘Save private key..." button
f. Click the general tab
g. Add the private key file that was generated by clicking the ‘Add Private Key...’
button
h. Close this dialog
7. From the main menu, select Window -> Show View -> Other...
8. Select CVS -> CVS Repositories and click ok
9. Right click in the CVS Repositories window and select New -> Repositories Location...
10. The following settings will need to be entered:

Host: cvs.sourceforge.net

Repository path: /cvsroot/jopt

User: your sf username

Password: your sf password

Connection type: ssh (use default port)

Check ‘Save password’ (this doesn’t use putty’s pageant)

11. Right click on Package Explorer and select New Project...

12. Select Java Project

13. Enter JOpt API as project name

14. Select ‘Create project at external location’ and navigate to the api directory located under
directory where project was checked out

15. Click ‘Next’ button

16. You will need to add the commons-logging.jar, log4j.jar, junit.jar and resource directory to
the build path

17. Click ‘Finish’ button

18. Right click on JOpt project in Packager, select Team -> Share Project...

19. A dialog should display indicating CVS directories already exist and you only need to
click Finish

20. Repeat this process for SPI, Example and Test

21. SPI will depend on the API project in the project build path

22. Example and Test will depend on both the API and SPI projects

23. The workspace should now be connected to CVS and ready for development

~poooTw



TortoiseCVS 1.8.1
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Ok, Corcel

The SSH parameters for version 1.8.1 are different than previous versions. You will need to add
-2 to the existing parameters. The parameters should look like this —1 “%u” “%h” -2
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